无法使用Xcode 7、7.0.1或7.1 Beta在具有iOS 9.0.1的设备上配置应用程序

2020/12/16 06:21 · ios ·  · 0评论

我一直尝试使用最新版本的Xcode 7.0.1(7A1001发布于9/28),先前版本的Xcode 7(7A218)以及Xcode 7.1 Beta 2(通过Instruments)对我的设备进行配置,但均未成功(7B75)。

我的设备是安装了iOS 9.0.1(iOS9的最新通用发行版)的iPhone 6+。我能够在此设备上运行/调试应用程序而不会出现问题。

在下面的屏幕截图中,您可以看到在所有版本的所有屏幕截图中,我的设备均已禁用(显示为灰色)。我能够配置运行iOS 8.4.1的其他设备,而不会出现任何问题。

当前版本的Xcode是否不支持针对iOS 9.0.1的性能分析,或者是否存在某种配置设置或已知的解决方法?

Xcode 7.0.1:
Xcode 7.0.1

Xcode 7.0:
Xcode 7.0

Xcode 7.1 beta 2:
Xcode 7.1 Beta 2

TL; DR-执行设备的完全重启;重新启动Xcode和工具;如果提示启用设备进行开发,请选择“打开Xcode”。

2016年3月31日更新:最新版本的Xcode(7.2.x,7.3)没有遇到任何问题,因此这里的稳定性似乎有所提高。


我相信我可能终于可以正常工作了。详细步骤:

  1. 从Mac上拔下设备的插头并完全关闭设备的电源(按住电源按钮几秒钟;滑动以关闭电源)。
  2. 关闭Xcode和仪器。
  3. 重新启动设备,并在完全启动后将其重新连接到Mac。
  4. 重新启动Xcode。在这里,我的设备显示为已禁用,Xcode指示该设备不可用。
  5. 打开您的项目;清理(​​Shift + Command + K),构建(Command + B),配置文件(Command + I)。
  6. 仪器启动后,我注意到该设备已启用。选择后,会显示一条消息,标题为“是否允许开发该设备?” 和消息“这将打开Xcode并启用此设备进行开发”。(请注意,即使我已经使用该设备进行开发,这只是我第一次执行此过程时发生的情况-而一些用户还报告说,他们没有看到此对话框。)

启用此设备进行开发?

  1. 点击“打开Xcode”。在这里Xcode并没有提示我任何事情,也没有显示任何东西-没有其他消息表明已完成任何事情,或者该设备已可用或不可用于开发。打开设备窗口,该设备似乎可用。(以后出现此情况时,我没有看到此选项。)
  2. 现在,我可以在“仪器”中选择设备并对其进行配置。

附带说明一下,我也再次能够从“设备”窗口中删除已安装的应用程序(我意识到以前无法做到这一点)。

我不确定我的设备如何以这种状态结束,但是我会一直监视是否继续发生这种情况。

请注意,这是使用Xcode 7.0.1完成的


更新:执行这些步骤后,我的设备似乎退回到无法进行性能分析-为了使该设备可用于性能分析,我不得不再次重新启动设备。不知道是什么触发了此行为,但是我将为此提交雷达。

关闭仪器->长按主屏幕和电源按钮重置设备->重新启动仪器。适用于Xcode 7.3。

根据对开发者论坛苹果员工对这个问题的行为在Xcode 7.3测试版有很大的提高,所以一个简单的解决方案是尝试升级的Xcode。我已经升级了,到目前为止看起来还不错。

XCode 10.3和iOS 12.4.2仍然会发生此问题

我只重新启动了设备,并且可以正常工作。

本文地址:http://ios.askforanswer.com/wufashiyongxcode-77-0-1huo7-1-betazaijuyouios-9-0-1deshebeishangpeizhiyingyongchengxu.html
文章标签: ,   ,   ,   ,  
版权声明:本文为原创文章,版权归 admin 所有,欢迎分享本文,转载请保留出处!

文件下载

老薛主机终身7折优惠码boke112

上一篇:
下一篇:

评论已关闭!